Author Topic: [SOLVED] Performance Issues in SSTC  (Read 1187 times)

Offline Cherenkov11

  • High Voltage Enthusiast
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
[SOLVED] Performance Issues in SSTC
« on: October 07, 2019, 05:08:34 PM »
Hi, I'm Andrew

IĀ“ve been working on my SSTC 2 by Loneoceans. Basically I did the same circuit except for the under voltage protection and instead of current transformer feedback I used a simple antenna.

Using a transformer for stepdown the main voltage to a more secure voltage for testing, giving me ~160 volts DC on the bus.  It works relatively well without a topload, giving nice 5-6 cm sparks with no skipping pulses.

But, for lower the resonant frecuency I added a topload, a small toroid, but for my surprise, it does not work well, start to skipping a lot of pulses, no matter where I place the the antenna. The length of the arc maintain mostly the same, maybe a little bit bigger, but thinner. But the problem is that it works very unreliably and most of the time it doesn't even work.

I don't like to use it without a topload, because the UCC get pretty hot at high pulse rates (I think maybe relate to the high resonance frecuency creating a lot of power switching loses).

I've been trying different lengths of antenna, changing the distance between my secondary coil and the antenna, I even change the circuit in the antenna, putting the capacitor before the clamping diodes and not after as Loneoceans' schematic shows, removing the 1k resistor before de 74HC14, using 1n5818 and 1n60 diodes for clamping but no help.

I hope you guys can help me.

Photo album

Regards, Andrew
« Last Edit: October 12, 2019, 04:00:24 PM by Cherenkov11 »

Offline davekni

  • High Voltage Engineer
  • ****
  • Posts: 444
  • Karma: +25/-0
  • Physicist, engineer (electronic), and hobbiest
    • View Profile
Re: Performance Issues in SSTC
« Reply #1 on: October 08, 2019, 04:47:48 AM »
My guess is that your primary resonant frequency is too high for the secondary with top load.  Increasing the size of the primary resonant cap should fix that issue.  Do you have a way to measure the resonant frequencies?
David Knierim

Offline Cherenkov11

  • High Voltage Enthusiast
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Performance Issues in SSTC
« Reply #2 on: October 08, 2019, 03:26:33 PM »
The secondary coil it's not exactly as the one that Loneoceans uses. But I calculated it with JavaTC to match the frequency of 250 Khz (but right now without the top load it should be at around 360 kHz), the primary coil is 6 turns, the same as Loneoceans uses and  with the same 4.7uF DC blocking capacitor. That according to JavaTC the resonant frequency is around 25 kHz, so, very low. (I added two more images to the Imgur album with the coils especifications). BTW, this is not a DRSSTC, so I don't have a 'resonant capacitor' on the primary side.
« Last Edit: October 08, 2019, 03:32:53 PM by Cherenkov11 »

Offline oneKone

  • High Voltage Engineer
  • ****
  • Posts: 314
  • Karma: +8/-0
    • View Profile
Re: Performance Issues in SSTC
« Reply #3 on: October 08, 2019, 04:01:35 PM »
Welcome to the forum @Cherenkov11

being an sstc the primary fres wouldn't have an effect on the operation of your coil, given your particular setup. Two things i would try:

*Get or make a simple square wave generator to give an output close to the resonant frequency, then drive the circuit with it. this will allow you to scope the gates of the mosfets to see if they're being driven properly.

*antenna feedback can be tricky, in my past coils even the slightest movements could change the performance of the driver. In the past i would have it extremely close to the coil (to the point i can see corona) then slowly move it away from the coil to avoid arcing to it.

I'd also check to see if the unused pins of the 74hc14 are grounded, as floating pins can be noisy to the triggers that are being used.

hopefully some of this is help.


Offline Cherenkov11

  • High Voltage Enthusiast
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Performance Issues in SSTC
« Reply #4 on: October 08, 2019, 04:40:35 PM »
Hi oneKone, unfortunately I don't have an oscilloscope to check if the gates of the IGBTs are being drive correctly. I've been trying a lot of setups for the antenna, different lengths, thickness of the antenna, but no results. If I put very closesly the antenna to the secondary coil, to the point that corona is visibled, the arcs get very tiny, 1-2cm; if I get the antenna far away it does not oscillate, so to the middle point it gives me almost good arcs, but works in very unreliable way, skipping almost half of the pulses, at high and low bps. Without the topload works pretty well, no skipping pulses, even at very high bps, and the distance range from the antenna to the coil is large, so the sweet spot is very easy to find, but the ucc get pretty hot quickly, the big no no is the topload, it mess up all.

When I started noticing that it was not working well, I revised all the antenna circuit, grounding all the unsed inputs of the 74HC14 (You can see it on the images), but it makes no difference.

« Last Edit: October 08, 2019, 04:47:47 PM by Cherenkov11 »

Offline davekni

  • High Voltage Engineer
  • ****
  • Posts: 444
  • Karma: +25/-0
  • Physicist, engineer (electronic), and hobbiest
    • View Profile
Re: Performance Issues in SSTC
« Reply #5 on: October 09, 2019, 05:02:45 AM »
Thank you for the clarification about the capacitor being for DC blocking and not resonance.  I saw the primary coil and a cap and made a bad assumption.  (My only SSTC drives the bottom wire of the "secondary" coil directly, so has no primary coil.)

Without scoping, debug is difficult.  Hopefully others here with more experience can guess what the issue is based on symptoms only.

Good luck!
David Knierim

Offline Mads Barnkob

  • Administrator
  • High Voltage Expert
  • *****
  • Posts: 1430
  • Karma: +24/-0
  • Denmark
    • View Profile
    • Kaizer Power Electronics
Re: Performance Issues in SSTC
« Reply #6 on: October 09, 2019, 09:12:47 AM »
Did you try to switch the primary coil wires around, in order to reverse the primary phasing?

You might be switching on a out-of-phase feedback signal and that would explain that it works with antenna really close, it is simply shoot-through, leakage and capacitively coupled energy through the system that gives a small spark.
http://www.kaizerpowerelectronics.dk - Tesla coils, high voltage, pulse power, audio and general electronics

Offline Cherenkov11

  • High Voltage Enthusiast
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Performance Issues in SSTC
« Reply #7 on: October 09, 2019, 03:18:10 PM »
Thank you for your responses. I haven't had much time recently, so no much testing on the coil. I'm going to try reversing the primary coil and testing another topload. Just a question,is there any difference between having the coupling capacitor on the antenna before or after the clamping diodes?. I've notice that Steve Wards and Mads use it right after the antenna, before the diodes. But in the LoneoceansĀ“solution use it after the clamping diodes and then an 1k resistor before the input pin of the UCC?

Offline Cherenkov11

  • High Voltage Enthusiast
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Performance Issues in SSTC
« Reply #8 on: October 10, 2019, 04:19:38 PM »
Thanks for your help Mads, you nailed it. Honestly I never thought that the primary coil was out-of-phase, even though that it is a basic troubleshooting, it never goes through my mind, because I assume that it was working right, since without a top load basically 'work' as expected, but yeah, in reality was all the opposite.

As soon as I switch the primery coil work soooo much different, super stable, an the antenna was no nearly as tricky as it was before, the IGBTs stay very cold, even with large sessions of working, very satisfied. Just the UCC warm up a little bit to much at high frequency pulses, but nothing out of control (maybe the resonant frequency is still very high, right now at about 300 Khz with the small toroid)

Here's a video of it

Now, I think there's room for improve the performace even more, is there any recommensation that I can apply on it?, mainly for bigger sparks. Right now is running at mains AC, with approximately 340 Vbus, and the spark at around 15cm.

Thanks in advance
Andrew.
« Last Edit: October 10, 2019, 05:44:51 PM by Cherenkov11 »

Offline Cherenkov11

  • High Voltage Enthusiast
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: [SOLVED] Performance Issues in SSTC
« Reply #9 on: January 31, 2020, 06:15:48 PM »
Hello again.

Just a little update on the status of the SSTC. I've been playing around with this coil, trying to extract the most power that I can. So far so good, now that I added the ground plane made of aluminum foil under the coil, it works so much better and reliable.

Now the arcs are around 17-18 cm, and thicker than before. Still I need to replace the top load for a better one, right now is made of steel, with a lot of resistance and losses, I'm going to try to find a bigger one and one made of aluminum.

I added new photos to the Imgur album of the new arcs and another Youtube video with the new setup.

High Voltage Forum

Re: [SOLVED] Performance Issues in SSTC
« Reply #9 on: January 31, 2020, 06:15:48 PM »

 


* Recent Topics and Posts

post Measuring LED efficiency
[Light, Lasers and Optics]
TMaxElectronics
Today at 12:46:23 AM
post Re: Configuration of a half bridge.
[Electronic Circuits]
hammertone
July 07, 2020, 10:28:37 PM
post Re: Configuration of a half bridge.
[Electronic Circuits]
ElectroXa
July 07, 2020, 10:09:22 PM
post Re: Configuration of a half bridge.
[Electronic Circuits]
hammertone
July 07, 2020, 09:36:53 PM
post Re: Configuration of a half bridge.
[Electronic Circuits]
johnf
July 07, 2020, 09:20:12 PM
post Configuration of a half bridge.
[Electronic Circuits]
hammertone
July 07, 2020, 09:07:10 PM
post Re: Help needed: HV Driver circuit
[Transformer (Ferrite Core)]
T3sl4co1l
July 06, 2020, 10:29:17 PM
post Re: induction heater troubleshooting help
[Electronic Circuits]
petespaco
July 06, 2020, 06:53:26 PM
post Re: adventures in homemade flyback bobbins.
[Transformer (Ferrite Core)]
HighVoltageRulezz
July 06, 2020, 01:18:03 PM
post Re: Help needed: HV Driver circuit
[Transformer (Ferrite Core)]
HighVoltageRulezz
July 06, 2020, 01:05:32 PM
post Re: Help needed: HV Driver circuit
[Transformer (Ferrite Core)]
T3sl4co1l
July 06, 2020, 06:14:56 AM
post Re: Cathodes in Compact Fluorescent Lamps
[Light, Lasers and Optics]
klugesmith
July 05, 2020, 06:31:21 PM
post Re: Cathodes in Compact Fluorescent Lamps
[Light, Lasers and Optics]
HiVi
July 05, 2020, 12:30:02 PM
post Re: IGBTs keep dying (un-solved again)
[Dual Resonant Solid State Tesla coils (DRSSTC)]
TMaxElectronics
July 04, 2020, 10:35:50 PM
post Re: IGBTs keep dying (un-solved again)
[Dual Resonant Solid State Tesla coils (DRSSTC)]
davekni
July 04, 2020, 08:56:15 PM
post Re: Next Gen DRSSTC
[Dual Resonant Solid State Tesla coils (DRSSTC)]
TMaxElectronics
July 04, 2020, 04:37:32 PM
post Re: IGBTs keep dying (un-solved again)
[Dual Resonant Solid State Tesla coils (DRSSTC)]
TMaxElectronics
July 04, 2020, 04:14:44 PM
post Dell PowerEdge M1000E Blade Server Teardown
[Computers, Microcontrollers, Programmable Logic, Interfaces and Displays]
Mads Barnkob
July 04, 2020, 01:52:14 PM
post Help needed: HV Driver circuit
[Transformer (Ferrite Core)]
HighVoltageRulezz
July 04, 2020, 12:37:48 PM
post Re: Easy to build Polyphonic MIDI Interrupter
[Computers, Microcontrollers, Programmable Logic, Interfaces and Displays]
Max
July 04, 2020, 12:17:47 AM
post Cathodes in Compact Fluorescent Lamps
[Light, Lasers and Optics]
klugesmith
July 03, 2020, 07:12:18 AM
post Re: What's needed to heat up 0.75 g of SiC (susceptor) mass until it turns dim-red??
[Radio Frequency]
klugesmith
July 03, 2020, 06:36:16 AM
post Re: IGBTs keep dying (un-solved again)
[Dual Resonant Solid State Tesla coils (DRSSTC)]
davekni
July 03, 2020, 04:20:42 AM
post Re: "Slayer exciter" analysis
[Solid State Tesla Coils (SSTC)]
acmq
July 03, 2020, 03:01:56 AM
post Re: Easy to build Polyphonic MIDI Interrupter
[Computers, Microcontrollers, Programmable Logic, Interfaces and Displays]
AstRii
July 02, 2020, 11:17:48 PM
post Re: How to prevent secondary oxidation / Rust
[Dual Resonant Solid State Tesla coils (DRSSTC)]
MRMILSTAR
July 02, 2020, 11:09:25 PM
post Re: Differential probe testing setup
[Laboratories, Equipment and Tools]
TMaxElectronics
July 02, 2020, 10:57:02 PM
post Re: Differential probe testing setup
[Laboratories, Equipment and Tools]
Twospoons
July 02, 2020, 10:47:18 PM
post Re: How to prevent secondary oxidation / Rust
[Dual Resonant Solid State Tesla coils (DRSSTC)]
johnf
July 02, 2020, 09:03:20 PM
post Re: How to prevent secondary oxidation / Rust
[Dual Resonant Solid State Tesla coils (DRSSTC)]
DJthefirst
July 02, 2020, 08:01:03 PM
post Re: Easy to build Polyphonic MIDI Interrupter
[Computers, Microcontrollers, Programmable Logic, Interfaces and Displays]
Max
July 02, 2020, 07:04:55 PM
post Re: How to prevent secondary oxidation / Rust
[Dual Resonant Solid State Tesla coils (DRSSTC)]
TMaxElectronics
July 02, 2020, 07:02:30 PM
post Re: IGBTs keep dying (solved for now)
[Dual Resonant Solid State Tesla coils (DRSSTC)]
TMaxElectronics
July 02, 2020, 06:51:20 PM
post Re: Easy to build Polyphonic MIDI Interrupter
[Computers, Microcontrollers, Programmable Logic, Interfaces and Displays]
AstRii
July 02, 2020, 05:34:23 PM
post Re: How to prevent secondary oxidation / Rust
[Dual Resonant Solid State Tesla coils (DRSSTC)]
DJthefirst
July 02, 2020, 05:09:09 PM
post Re: How to prevent secondary oxidation / Rust
[Dual Resonant Solid State Tesla coils (DRSSTC)]
TMaxElectronics
July 02, 2020, 12:51:29 PM
post Differential probe testing setup
[Laboratories, Equipment and Tools]
TMaxElectronics
July 02, 2020, 12:20:18 PM
post Re: How to prevent secondary oxidation / Rust
[Dual Resonant Solid State Tesla coils (DRSSTC)]
MRMILSTAR
July 02, 2020, 05:30:41 AM
post How to prevent secondary oxidation / Rust
[Dual Resonant Solid State Tesla coils (DRSSTC)]
DJthefirst
July 02, 2020, 04:16:58 AM
post Re: induction heater troubleshooting help
[Electronic Circuits]
petespaco
July 02, 2020, 01:02:02 AM
post Re: What's needed to heat up 0.75 g of SiC (susceptor) mass until it turns dim-red??
[Radio Frequency]
T3sl4co1l
July 01, 2020, 06:54:30 AM
post Re: "Slayer exciter" analysis
[Solid State Tesla Coils (SSTC)]
T3sl4co1l
July 01, 2020, 06:25:30 AM
post Re: "Slayer exciter" analysis
[Solid State Tesla Coils (SSTC)]
acmq
July 01, 2020, 02:47:13 AM
post Re: A three-phase "tree phase" Tesla coil
[Dual Resonant Solid State Tesla coils (DRSSTC)]
Steve Ward
July 01, 2020, 02:43:34 AM
post Re: induction heater troubleshooting help
[Electronic Circuits]
aes92000
July 01, 2020, 02:33:07 AM
post Re: induction heater troubleshooting help
[Electronic Circuits]
petespaco
July 01, 2020, 12:03:08 AM
post Re: induction heater troubleshooting help
[Electronic Circuits]
aes92000
June 30, 2020, 10:34:36 PM
post Re: E-Bay Marx generator
[Voltage Multipliers]
ritaismyconscience
June 30, 2020, 09:14:06 PM
post Re: What's needed to heat up 0.75 g of SiC (susceptor) mass until it turns dim-red??
[Radio Frequency]
ritaismyconscience
June 30, 2020, 09:05:32 PM
post Re: induction heater troubleshooting help
[Electronic Circuits]
ritaismyconscience
June 30, 2020, 09:01:55 PM

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 
SimplePortal 2.3.6 © 2008-2014, SimplePortal