Author Topic: SSTC Audio Interrupter Issues  (Read 839 times)

Offline DannyBoiSK

  • High Voltage Enthusiast
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
SSTC Audio Interrupter Issues
« on: January 26, 2019, 03:34:49 AM »
Hello everyone!

Long time lurker but new poster here. I've successfully built my first Tesla Coil following Steve Ward's Mini SSTC5 schematic. Everything is working well, I'm getting nice long streamers and the stock interrupter works perfectly.

I have attempted to do some audio interrupting with this SSTC, and I've had some mixed luck with it. I managed to get an Arduino to interrupt pre-programmed MIDI songs, which works alright, however I would like to be able to interrupt with a mono audio signal, such as from an electric guitar or a smartphone.

I found Martin Ebbefeld's Musical SSTC interrupter circuit online, and purchased all the required parts and built it. However, I'm unable to get it to work as it should. The circuit is shown below for reference:

http://kaizerpowerelectronics.dk/wp-content/gallery/2016_09_03_-_music_modulator/musicmodulator.gif



I had to swap 2 parts out; the LM741 for a UA741CP, which should be alright as it was recommended as a direct replacement on DigiKey. I also had to use 2N3904BU transistors instead of the recommended BC547's, but these were also listed as a direct replacement so it *should* be okay.

I've assembled the circuit as shown, twice actually. Soldered one up and left the other on a breadboard. They both have the same result. The audio input signal looks great, I can see it on my oscilloscope at around ~1V. The output from the LM741 doesn't appear to be amplified, if anything it looks like the peaks of the waves are chopped off and there is no negative cycles on the waveform. The trigger into the 555 timer, which should be a pulse at the same frequency as the notes, is just held at 12v. The output is also held at 12v.

The R14 100R resistor from +9v to the collector of Q6 is also uncomfortably hot, I've actually burned my finger on it a few times. This behaviour is consistent on both the soldered and the breadboarded circuits I've made up. I was also blowing through 555 timers like crazy, but that is unrelated and due to a stupid mistake I made where i was shorting the 9v supply across it.

I will try to take some pictures of some waveforms and come back and post them. If anyone has any input as to why this isn't working it would be much appreciated!


EDIT: Waveforms! (Also, I now realize how hard it is to take decent pictures of a waveform on an analog oscilloscope! Sorry!)

This is my audio input signal from my smartphone. Currently just using varying frequencies of sine waves to test.




This is with the input audio on the top, and the input to my UA741 below. The signal is getting to the amp perfectly without any degradation:




Now here is where I'm a bit lost. This is the waveform that is output from the UA741 on the bottom, with audio input signal on top:




The waveform is practically flat. I double checked my connections and all wiring to the amp is as shown on the main circuit diagram.

Waveforms with higher frequencies tend to be less flat:







As expected, the input to the 555 is incorrect and the output from the 555 is as well.

Here are some pictures of the interrupters construction:

Soldered version with space to add on a PWM interrupting mode, as well as an input for my electric guitar:





And the breadboard version I was using to double check i hadn't screwed up my soldered version:






And finally some slow-mo videos of the SSTC in action with the stock interrupter:



-Daniel
« Last Edit: January 26, 2019, 05:56:10 AM by DannyBoiSK »

Offline FilipŠebík

  • High Voltage Enthusiast
  • *
  • Posts: 34
  • Karma: +1/-0
    • View Profile
Re: SSTC Audio Interrupter Issues
« Reply #1 on: January 27, 2019, 07:42:26 AM »
On the breadboard version, you have the 1K R12 pulling the base of Q5 high. It is supposed to be pulling it low, so connect it to the ground

Offline DannyBoiSK

  • High Voltage Enthusiast
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: SSTC Audio Interrupter Issues
« Reply #2 on: January 27, 2019, 05:59:34 PM »
On the breadboard version, you have the 1K R12 pulling the base of Q5 high. It is supposed to be pulling it low, so connect it to the ground

Good eye! Thanks! I had it pulling to ground on the soldered version, just swapped it on the breadboard as well, thanks for noticing. As soon as I swapped it, the breadboard version R14 100R resistor heated up like crazy. Actually burned my finger seeing how hot it was. Any ideas as to why this would be happening?

Offline Laci

  • High Voltage Engineer
  • ****
  • Posts: 209
  • Karma: +6/-0
    • View Profile
Re: SSTC Audio Interrupter Issues
« Reply #3 on: January 27, 2019, 06:19:10 PM »
Q6 is pulled high via R13,so the current across R14 will be the supply voltage / R14 .The power dissipation will be this current squared x R14  ,in  your case over the 0.25W maximum of the resistor.If no signal is at the Q5 base,it will never turn on to pull Q6 base to ground,decreasing the current across R14.
Try using over a 1W resistor for R14 or replace the op amp if that's not working.
« Last Edit: January 27, 2019, 06:20:51 PM by Laci »

Offline DannyBoiSK

  • High Voltage Enthusiast
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: SSTC Audio Interrupter Issues
« Reply #4 on: January 27, 2019, 07:17:23 PM »
Q6 is pulled high via R13,so the current across R14 will be the supply voltage / R14 .The power dissipation will be this current squared x R14  ,in  your case over the 0.25W maximum of the resistor.If no signal is at the Q5 base,it will never turn on to pull Q6 base to ground,decreasing the current across R14.
Try using over a 1W resistor for R14 or replace the op amp if that's not working.

Thanks for your suggestion! Ill go try a 1W right now.

I've already replaced the op-amp a few times, but I have a couple more so I'll swap one in and see if it works, and report back.

Thanks everyone for their help so far!

Offline DannyBoiSK

  • High Voltage Enthusiast
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: SSTC Audio Interrupter Issues
« Reply #5 on: January 27, 2019, 08:09:56 PM »
Q6 is pulled high via R13,so the current across R14 will be the supply voltage / R14 .The power dissipation will be this current squared x R14  ,in  your case over the 0.25W maximum of the resistor.If no signal is at the Q5 base,it will never turn on to pull Q6 base to ground,decreasing the current across R14.
Try using over a 1W resistor for R14 or replace the op amp if that's not working.

Okay! Just tried this out. Replaced the R14 with a 1W resistor of the same value, and swapped in the op amp for a new one. Same issue as before. The now 1W R14 resistor is still getting warm. The circuit is drawing ~120mA. Probed the audio input which is nice and clean, and the input to the op amp is identical to the audio input. Probing the output (Pin 6 of the op amp) Shows a completely flat line on the scope, with the same settings on the scope.

I'm wondering if possibly the op amp isn't liking the supply voltage. On the datasheet for both the UA741 and the original circuit designed LM741, it shows that you need a positive and negative voltage input, not just positive and GND. I dont think this is the issue though, as the circuit has worked for other users powered off a single 9v battery.

The user "nabzim" has successfully made this circuit here: https://highvoltageforum.net/index.php?topic=93.0 

He uses a single 9v battery as his power source. I've checked my circuit against his and it all looks alright. He's even using a 1/4W 100R resistor for R14, 1W not needed.

Any more suggestions would be appreciated!

Thanks!

Offline nabzim

  • High Voltage Enthusiast
  • *
  • Posts: 24
  • Karma: +0/-0
  • My full name is Adam Baltazar Mizban. Hello there!
    • View Profile
    • My YouTube Channel
Re: SSTC Audio Interrupter Issues
« Reply #6 on: January 28, 2019, 05:48:53 PM »
Hello!
I am sorry, but my knowledge in electronics is quite limited... (However, I have finally began my first semester of classes after changing my Major to Electrical Engineering. I was previously a Chemistry Major ::) So, I may be able to help within the next year or two... Hahahaha)

If it helps at all, my op-amp is a UA741CN and my transistors are 2N3904.
I was using a 9-volt battery originally, but I switched to using a small dc-dc converter to supply the 9V.
The interrupter still works great to this day, however thinking about it, I've never touched any of the resistors to see if they get warm... I may have time later today or another day this week to try that out.
I apologise for my lack of usefulness in your pursuit of troubleshooting the issue. I'm sure that Mads Barnkob will also give his input (eventually ;)), as he's pretty good about replying to everyone's posts.

Offline Cameron Prince

  • High Voltage Enthusiast
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
    • Tesla Universe
Re: SSTC Audio Interrupter Issues
« Reply #7 on: April 01, 2019, 11:09:55 PM »
Hi,

I ran across this thread today and noticed your substitution of 2N3904 for BC547. Did you, hopefully, catch that the pinout for these is different? 2N3904 is EBC and BC547 is CBE.

This has bit me before...

Cameron

High Voltage Forum

Re: SSTC Audio Interrupter Issues
« Reply #7 on: April 01, 2019, 11:09:55 PM »

 


* Recent Topics and Posts

post Re: adventures in homemade flyback bobbins.
[Transformer (ferrite core)]
ElectroXa
Today at 02:22:09 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
petespaco
August 19, 2019, 09:08:12 PM
post Re: Drsstc 3
[Dual Resonant Solid State Tesla coils]
Netzpfuscher
August 19, 2019, 02:27:06 PM
post Flashing light prize 2019
[Electronic circuits]
Avalanche
August 19, 2019, 02:12:41 PM
post Re: Drsstc 3
[Dual Resonant Solid State Tesla coils]
Hydron
August 19, 2019, 10:44:35 AM
post Re: Drsstc 3
[Dual Resonant Solid State Tesla coils]
Netzpfuscher
August 19, 2019, 07:37:07 AM
post Re: Drsstc 3
[Dual Resonant Solid State Tesla coils]
oneKone
August 19, 2019, 03:29:24 AM
post Re: My second DRSSTC
[Dual Resonant Solid State Tesla coils]
erdal
August 18, 2019, 05:05:24 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
Bert911
August 18, 2019, 01:04:35 PM
post Re: You would think this would be easy to find.
[Spark gap Tesla coils]
thedoc298
August 17, 2019, 11:09:16 PM
post Re: You would think this would be easy to find.
[Spark gap Tesla coils]
thedoc298
August 17, 2019, 11:00:32 PM
post Re: You would think this would be easy to find.
[Spark gap Tesla coils]
Fumeaux
August 17, 2019, 09:44:07 PM
post You would think this would be easy to find.
[Spark gap Tesla coils]
thedoc298
August 17, 2019, 09:01:00 PM
post Re: Twin System Build
[Dual Resonant Solid State Tesla coils]
Mads Barnkob
August 17, 2019, 08:06:42 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
Lane
August 17, 2019, 10:45:26 AM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
Lane
August 17, 2019, 06:21:45 AM
post Re: My second DRSSTC
[Dual Resonant Solid State Tesla coils]
Hydron
August 17, 2019, 12:59:20 AM
post Re: Twin System Build
[Dual Resonant Solid State Tesla coils]
fnordest
August 17, 2019, 12:18:48 AM
post Re: Drsstc 3
[Dual Resonant Solid State Tesla coils]
Mads Barnkob
August 16, 2019, 10:34:46 PM
post Re: Teardown of Danfoss VLT6000 4kW Variable Frequency Drive
[Electronic circuits]
Mads Barnkob
August 16, 2019, 10:26:19 PM
post Re: My second DRSSTC
[Dual Resonant Solid State Tesla coils]
Mads Barnkob
August 16, 2019, 10:19:18 PM
post Re: [Development] Project of an SSTC driver.
[Solid state Tesla coils]
Mads Barnkob
August 16, 2019, 10:07:31 PM
post Re: Suitable capacitors and switches? 10kV
[Capacitor banks]
T3sl4co1l
August 16, 2019, 09:28:35 PM
post Re: Suitable capacitors and switches? 10kV
[Capacitor banks]
ElectroXa
August 16, 2019, 09:17:04 PM
post Re: ESAB Power TIG 200 Welder Teardown
[Electronic circuits]
T3sl4co1l
August 16, 2019, 09:14:36 PM
post ESAB Power TIG 200 Welder Teardown
[Electronic circuits]
Mads Barnkob
August 16, 2019, 08:03:18 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
petespaco
August 16, 2019, 01:49:53 PM
post Suitable capacitors and switches? 10kV
[Capacitor banks]
MrFox
August 16, 2019, 12:21:36 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
Lane
August 16, 2019, 11:22:45 AM
post Re: Small Phase change build R600a
[General chatting]
DashApple
August 15, 2019, 06:23:40 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
rikkitikkitavi
August 15, 2019, 06:17:55 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
Lane
August 15, 2019, 01:51:04 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
petespaco
August 14, 2019, 07:05:57 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
Bert911
August 14, 2019, 03:42:34 PM
post Re: Van de Graaf is leaking charge
[Static electricity]
Patric
August 14, 2019, 02:56:49 PM
post Re: Van de Graaf is leaking charge
[Static electricity]
ElectroXa
August 14, 2019, 01:42:21 PM
post Re: My second DRSSTC
[Dual Resonant Solid State Tesla coils]
erdal
August 14, 2019, 12:53:10 PM
post Van de Graaf is leaking charge
[Static electricity]
Patric
August 14, 2019, 09:22:21 AM
post Re: Drsstc 3
[Dual Resonant Solid State Tesla coils]
oneKone
August 14, 2019, 04:39:11 AM
post Re: MMC orientation and variac
[Spark gap Tesla coils]
thedoc298
August 13, 2019, 07:10:31 PM
post Re: MMC orientation and variac
[Spark gap Tesla coils]
MRMILSTAR
August 13, 2019, 05:17:23 AM
post MMC orientation and variac
[Spark gap Tesla coils]
thedoc298
August 12, 2019, 09:54:35 PM
post Re: My second DRSSTC
[Dual Resonant Solid State Tesla coils]
erdal
August 12, 2019, 08:40:16 PM
post Re: Small Phase change build R600a
[General chatting]
Hydron
August 12, 2019, 07:27:23 PM
post Re: Teardown of Danfoss VLT6000 4kW Variable Frequency Drive
[Electronic circuits]
klugesmith
August 12, 2019, 09:18:15 AM
post Re: Teardown of Danfoss VLT6000 4kW Variable Frequency Drive
[Electronic circuits]
shrad
August 12, 2019, 09:06:34 AM
post Re: Teardown of Danfoss VLT6000 4kW Variable Frequency Drive
[Electronic circuits]
klugesmith
August 12, 2019, 09:02:38 AM
post Re: A problem solved with hand tools
[General chatting]
klugesmith
August 12, 2019, 08:29:20 AM
post Re: Ebay [US]: MITSUBISHI CM300 1200V-300A IGBT (30$ a piece)
[Sell / Buy / Trade]
oneKone
August 12, 2019, 05:25:24 AM
post Re: Ebay [US]: MITSUBISHI CM300 1200V-300A IGBT (30$ a piece)
[Sell / Buy / Trade]
acobaugh
August 10, 2019, 08:14:35 PM

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30