Author Topic: IGBTs keep dying (un-solved again)  (Read 2591 times)

Offline TMaxElectronics

  • High Voltage Experimenter
  • **
  • Posts: 78
  • Karma: +3/-0
    • View Profile
    • My random (and very empty) electronics blog
Re: IGBTs keep dying
« Reply #40 on: June 27, 2020, 11:50:55 AM »
So far the problems seem to have disappeared (at least at 120V primary voltage) after a few days of testing (really just messing around :P).

Quote
i would be investigating gate waveforms for voltage transients
If any issues pop up again I'll make sure to check that!

I'm using ACURA107-HF 1kV 1A diodes and so far they seem to be holding up fine. They have 75ns of reverse recovery time. But then again the reverse voltage was limited for now... still very interesting that out of all things the diodes would fail ;)
I guess the larger blocking size of the depletion region makes the re-diffusion take longer once forward conduction switches to reverse blocking.

Quote
and bump up the power supply to compensate.
Though my issue was not solved with two diodes in series, that was was solved the problems for me too.
As we have figured out earlier in this thread, the fact that my driver simply stops switching instead of pulling both legs of the bridge low combined with a large bootstrap charge resistor and the voltage drop across the bottom transistor, caused the bootstrap voltage to drop < 13.5V resulting in occasional (random, depending on where the controller stopped) shock heating of the top IGBT. That then proceeded to kill itself and shorted out (but with low energy, as it was on at the time of failure and the voltage across it was close to zero anyway), and then as the bottom transistor switched, it basically had shoot through from hell, as it tried to short out the VBus and promptly blew up (violently)


Offline TMaxElectronics

  • High Voltage Experimenter
  • **
  • Posts: 78
  • Karma: +3/-0
    • View Profile
    • My random (and very empty) electronics blog
Re: IGBTs keep dying (solved for now)
« Reply #41 on: July 02, 2020, 06:51:20 PM »
OK the caps are replaced, BUT the situation seems to still be similar...
I did a test run with 330A Ilim, which at 100us on time triggered almost all the time with more than 180V primary voltage. Turning it up resulted in moaaarrr power (obviously ;)), but it still kept triggering. once I turned up the primary voltage to the full 350V, the IGBT died once again...  ::)
On a positive note I am getting quite fast at taking apart the bridge and changing transistors&drivers  ;D

I measured the voltage across the bulk caps at that time:


I initially thought that it was good enough, but obviously wasn't. I realised kind of too late that I should probably measure directly across the IGBTs. After replacing the two transistors, I got this (directly on the screw terminals of the IGBTs):

This was at only 100V, with a very low (idk what exact level) current limit... and the Vpp was still significant.

My initial guess (before the second measurement) was that perhaps the OCD started sending random gate pulses, but further testing showed that it worked without issue (at least at a lower limiter level).
I also verified the top gate voltage, and detected no droop whatsoever, even if the idle state of that half was high. (only tested this at the limited current though)
So maybe the high current in the first test resulted in very high ringing voltages? But even if those peaks were significant, they would still need to exceed 300V to go above the VCEmax of the IGBTs  ???

And where does that ringing still come from now? With the two new caps we should be at ~125kHz resonance of the bus (maybe still too close)... I'm wondering if maybe an increase in inductance from the bulk caps might actually help in this case.
Just using a longer cable to attach them, instead of mounting the on the top upside down.

Max (the guy that has the other midi interrupter project) also had the idea that tuning was bad, resulting in poor energy transfer to the secondary, allowing the current to increase faster than normal, and was also concerned about the high ringing voltage, after the switching stopped.

And sorry about the screenshots coming from my phone, the diff. probe uses the power from the usb port ::)

EDIT:
I just tested this with the bulk caps connected trough cables, an it does seem to have reduced the frequency of the ringing, and almost removed the oscillations while switching. But the ringing is even larger than it was last time.
The caps were connected using ~10cm of welding cable. I'll try removing some of the film bypass caps tomorrow.

I also connected the CT to the scope again, as the first two images are extremely confusing without it.
« Last Edit: July 02, 2020, 10:21:09 PM by TMaxElectronics »

Offline davekni

  • High Voltage Engineer
  • ****
  • Posts: 470
  • Karma: +26/-0
  • Physicist, engineer (electronic), and hobbiest
    • View Profile
Re: IGBTs keep dying (un-solved again)
« Reply #42 on: July 03, 2020, 04:20:42 AM »
I'd suggest not removing any of your film capacitors, nor extending bulk cap connections.  It looks like the new VBus resonant frequency is now a bit closer to 1x primary frequency rather than 2x as it had been.  That can be seen as higher ripple voltage after enable ends.  (Most builds don't have an issue at 1x primary frequency since all IGBTs are off after enable ends.)  However, I wouldn't use caps to tweak frequency.

Instead, I'd work to block the magnetic field loop I described in a previous reply.  Ideally add some copper foil from the bulk cap bus bars that folds down over the film capacitors.  Or thinner strips from each conducting standoff across to the corresponding non-conductive standoff at the other end, passing along the outside edge of the bulk caps, and wide enough to go from almost the ECB to almost (or touching) the bus bars.  (The version with foil attached to the bus bars is a bit better.  It doesn't even need to make electrical contact along the bar.  Copper foil tape applied to the bus bars could connect only at the screws at the ends, and fold down over the film caps.)  The foil will both increase VBus resonant frequency and lower Q.

Voltage ringing on VBus at IGBTs will depend mostly on primary current, and only slightly on VBus voltage.  The short spikes may change more with voltage, but the main waveform shouldn't.  So, a good scoping of current and VBus voltage ripple will allow extrapolation to see if it's close to an issue (if ripple would approach 300V at full current).  You'll still need some additional margin for the short spikes.

A couple other possibilities on what may be causing frying:

1) With your off-state leaving two IGBTs enabled, those two are taking all the current after enable ends, rather than being split evenly among all four.  That also makes ring-down after enable last much longer since it's not feeding power back into VBus.  That makes higher transient thermal power for two IGBTs, starting after the die are already hot from the normal enable pulse operation.

2) During the enable pulse, IGBT diodes conduct relatively-small currents, only briefly between IGBT turn-off and current zero-crossing.  After enable ends, IGBT diodes conduct full primary current.  I wonder if forward-drop of the low-side IGBT diode is enough to over-charge that bootstrap capacitor and fry the gate driver chip.

3) Similar to (2) above, the low-side diode drop might directly violate driver-chip specifications for how far below ground the half-bridge output pin is allowed to go.  I haven't looked back at the thread to see which driver chip, so don't know if this is a likely issue or not.

Good luck on keeping IGBTs alive!
David Knierim

Offline TMaxElectronics

  • High Voltage Experimenter
  • **
  • Posts: 78
  • Karma: +3/-0
    • View Profile
    • My random (and very empty) electronics blog
Re: IGBTs keep dying (un-solved again)
« Reply #43 on: July 04, 2020, 04:14:44 PM »
Quote
1) With your off-state leaving two IGBTs enabled, those two are taking all the current after enable ends, rather than being split evenly among all four.  That also makes ring-down after enable last much longer since it's not feeding power back into VBus.  That makes higher transient thermal power for two IGBTs, starting after the die are already hot from the normal enable pulse operation.
This might very well be part of the problem.

After a lot of thinking I have come to the conclusion that, since I need to re-design the logic in the driver anyway (the filter workarounds worked but were very crappy, and a workaround for the idle state would be hard), I may as well implement a commonly used design... You may even say a next-gen one ;)

So i have made a 100% compatible version of the UD3:

The silkscreen is fixed in the most recent revision ;)

I'll hopefully not continue the story with it in this thread :D

Quote
the low-side diode drop might directly violate driver-chip specifications for how far below ground the half-bridge output pin is allowed to go
Interesting idea. The driver has a VMax at the common connection of -9V if i understand the datasheet correctly. (https://www.st.com/resource/en/datasheet/l6494.pdf)
« Last Edit: July 04, 2020, 05:04:15 PM by TMaxElectronics »

Offline davekni

  • High Voltage Engineer
  • ****
  • Posts: 470
  • Karma: +26/-0
  • Physicist, engineer (electronic), and hobbiest
    • View Profile
Re: IGBTs keep dying (un-solved again)
« Reply #44 on: July 04, 2020, 08:56:15 PM »
Yes, -9V looks correct per that specification.  You'd almost certainly hit the VBoot-Vout absolute-maximum rating of 21V first.

Have fun with your UD3C!
David Knierim

Offline TMaxElectronics

  • High Voltage Experimenter
  • **
  • Posts: 78
  • Karma: +3/-0
    • View Profile
    • My random (and very empty) electronics blog
Re: IGBTs keep dying (un-solved again)
« Reply #45 on: July 04, 2020, 10:35:50 PM »
Quote
You'd almost certainly hit the VBoot-Vout absolute-maximum rating of 21V first.
I'll measure it once the new driver is made. I also included an easily reachable pot for adjusting the gate drive voltage on the digital output/step down daughter board, so I can tune it more easily.

High Voltage Forum

Re: IGBTs keep dying (un-solved again)
« Reply #45 on: July 04, 2020, 10:35:50 PM »

 


* Recent Topics and Posts

post Re: Easy to build Polyphonic MIDI Interrupter
[Computers, Microcontrollers, Programmable Logic, Interfaces and Displays]
Max
Today at 07:02:24 PM
post Air Gap: why and how much?
[Transformer (Ferrite Core)]
HighVoltageRulezz
Today at 06:23:24 PM
post Re: making HV bobbins for ferrite transformers
[Transformer (Ferrite Core)]
HighVoltageRulezz
Today at 06:15:16 PM
post Re: How about some Tesla Coil memes
[General Chat]
AstRii
Today at 05:26:47 PM
post Re: First DRSSTC, No Sparks on Breakout
[Dual Resonant Solid State Tesla coils (DRSSTC)]
TMaxElectronics
Today at 05:25:43 PM
post Re: How about some Tesla Coil memes
[General Chat]
TMaxElectronics
Today at 05:23:40 PM
post Re: First DRSSTC, No Sparks on Breakout
[Dual Resonant Solid State Tesla coils (DRSSTC)]
AstRii
Today at 05:23:37 PM
post Re: Bipolar high voltage multiplier project - more than 70cm hot arc discharge
[Voltage Multipliers]
kilovolt
Today at 01:44:24 PM
post How about some Tesla Coil memes
[General Chat]
AstRii
Today at 01:09:16 PM
post First DRSSTC, No Sparks on Breakout
[Dual Resonant Solid State Tesla coils (DRSSTC)]
Yak
Today at 12:41:06 PM
post Re: X-ray image intensifier
[X-ray]
AlexanderHun
Today at 11:01:46 AM
post Re: Easy to build Polyphonic MIDI Interrupter
[Computers, Microcontrollers, Programmable Logic, Interfaces and Displays]
AstRii
Today at 02:09:13 AM
post Re: Charging a LiPo Battery with an LED driver
[Electronic Circuits]
davekni
August 12, 2020, 11:08:35 PM
post Re: making HV bobbins for ferrite transformers
[Transformer (Ferrite Core)]
davekni
August 12, 2020, 10:49:52 PM
post Re: Moving to a new lab!
[Laboratories, Equipment and Tools]
Mads Barnkob
August 12, 2020, 10:30:54 PM
post Re: making HV bobbins for ferrite transformers
[Transformer (Ferrite Core)]
Teravolt
August 12, 2020, 09:00:50 PM
post Re: making HV bobbins for ferrite transformers
[Transformer (Ferrite Core)]
SteveN87
August 12, 2020, 07:16:43 PM
post Re: making HV bobbins for ferrite transformers
[Transformer (Ferrite Core)]
Teravolt
August 12, 2020, 02:54:33 PM
post Re: Charging a LiPo Battery with an LED driver
[Electronic Circuits]
TMaxElectronics
August 12, 2020, 12:42:50 PM
post Re: Charging a LiPo Battery with an LED driver
[Electronic Circuits]
Twospoons
August 12, 2020, 12:23:58 PM
post Re: Single sided use of Xray XFMR
[Transformer (Ferrite Core)]
HighVoltageRulezz
August 12, 2020, 11:15:07 AM
post Re: making HV bobbins for ferrite transformers
[Transformer (Ferrite Core)]
davekni
August 12, 2020, 04:41:24 AM
post Re: Charging a LiPo Battery with an LED driver
[Electronic Circuits]
davekni
August 12, 2020, 04:06:09 AM
post Re: Charging a LiPo Battery with an LED driver
[Electronic Circuits]
TMaxElectronics
August 12, 2020, 01:58:47 AM
post Re: Charging a LiPo Battery with an LED driver
[Electronic Circuits]
Twospoons
August 12, 2020, 12:56:02 AM
post Charging a LiPo Battery with an LED driver
[Electronic Circuits]
TMaxElectronics
August 11, 2020, 11:24:18 PM
post Re: making HV bobbins for ferrite transformers
[Transformer (Ferrite Core)]
Teravolt
August 11, 2020, 06:34:05 PM
post Re: Fun with wireless power
[Solid State Tesla Coils (SSTC)]
Lightning On Demand
August 11, 2020, 04:19:01 AM
post Re: Fun with wireless power
[Solid State Tesla Coils (SSTC)]
Lightning On Demand
August 11, 2020, 04:17:27 AM
post Re: Fun with wireless power
[Solid State Tesla Coils (SSTC)]
Lightning On Demand
August 11, 2020, 04:10:34 AM
post Re: Single sided use of Xray XFMR
[Transformer (Ferrite Core)]
klugesmith
August 11, 2020, 03:33:02 AM
post Single sided use of Xray XFMR
[Transformer (Ferrite Core)]
HighVoltageRulezz
August 10, 2020, 12:23:05 PM
post Re: XRay Tank- any ideas about what is inside
[Transformer (Ferrite Core)]
HighVoltageRulezz
August 10, 2020, 12:18:04 PM
post Re: making HV bobbins for ferrite transformers
[Transformer (Ferrite Core)]
johnf
August 10, 2020, 10:24:54 AM
post Re: making HV bobbins for ferrite transformers
[Transformer (Ferrite Core)]
davekni
August 10, 2020, 06:20:04 AM
post Re: Welcome new members, come say hello and tell a little about yourself :)
[General Chat]
RoadReaper
August 10, 2020, 05:40:19 AM
post Re: Easy to build Polyphonic MIDI Interrupter
[Computers, Microcontrollers, Programmable Logic, Interfaces and Displays]
Max
August 10, 2020, 02:07:26 AM
post making HV bobbins for ferrite transformers
[Transformer (Ferrite Core)]
Teravolt
August 10, 2020, 01:27:22 AM
post A Tesla coil and an antenna
[General Chat]
TheFreq
August 09, 2020, 09:02:32 PM
post Re: Fun with wireless power
[Solid State Tesla Coils (SSTC)]
Steve Ward
August 08, 2020, 10:22:04 PM
post Re: Fun with wireless power
[Solid State Tesla Coils (SSTC)]
T3sl4co1l
August 08, 2020, 03:36:40 PM
post Re: Fun with wireless power
[Solid State Tesla Coils (SSTC)]
acmq
August 08, 2020, 02:07:52 AM
post Re: LSI Nitrogen Laser tear-down and Homemade TEA Nitrogen and Dye Lasers
[Light, Lasers and Optics]
LesWright
August 06, 2020, 10:20:12 PM
post Re: LSI Nitrogen Laser tear-down and Homemade TEA Nitrogen and Dye Lasers
[Light, Lasers and Optics]
Weston
August 06, 2020, 08:45:59 PM
post Re: Cathodes in Compact Fluorescent Lamps
[Light, Lasers and Optics]
klugesmith
August 06, 2020, 05:41:04 PM
post Re: Dual MOT tesla coil
[Spark Gap Tesla Coils (SGTC)]
Jun
August 06, 2020, 03:53:58 PM
post LSI Nitrogen Laser tear-down and Homemade TEA Nitrogen and Dye Lasers
[Light, Lasers and Optics]
LesWright
August 06, 2020, 03:28:14 PM
post Re: Easy to build Polyphonic MIDI Interrupter
[Computers, Microcontrollers, Programmable Logic, Interfaces and Displays]
AstRii
August 06, 2020, 12:59:03 PM
post Re: Easy to build Polyphonic MIDI Interrupter
[Computers, Microcontrollers, Programmable Logic, Interfaces and Displays]
Mads Barnkob
August 06, 2020, 10:51:43 AM
post Re: How much is the voltage used in Corona Discharge tubes for ozone Generation?
[Transformer (Ferrite Core)]
UB_Serpent
August 06, 2020, 08:40:57 AM

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 
SimplePortal 2.3.6 © 2008-2014, SimplePortal