Author Topic: IGBTs keep dying (un-solved again)  (Read 3414 times)

Offline TMaxElectronics

  • High Voltage Technician
  • ***
  • Posts: 111
  • Karma: +5/-0
    • View Profile
    • My random (and very empty) electronics blog
Re: IGBTs keep dying
« Reply #40 on: June 27, 2020, 11:50:55 AM »
So far the problems seem to have disappeared (at least at 120V primary voltage) after a few days of testing (really just messing around :P).

Quote
i would be investigating gate waveforms for voltage transients
If any issues pop up again I'll make sure to check that!

I'm using ACURA107-HF 1kV 1A diodes and so far they seem to be holding up fine. They have 75ns of reverse recovery time. But then again the reverse voltage was limited for now... still very interesting that out of all things the diodes would fail ;)
I guess the larger blocking size of the depletion region makes the re-diffusion take longer once forward conduction switches to reverse blocking.

Quote
and bump up the power supply to compensate.
Though my issue was not solved with two diodes in series, that was was solved the problems for me too.
As we have figured out earlier in this thread, the fact that my driver simply stops switching instead of pulling both legs of the bridge low combined with a large bootstrap charge resistor and the voltage drop across the bottom transistor, caused the bootstrap voltage to drop < 13.5V resulting in occasional (random, depending on where the controller stopped) shock heating of the top IGBT. That then proceeded to kill itself and shorted out (but with low energy, as it was on at the time of failure and the voltage across it was close to zero anyway), and then as the bottom transistor switched, it basically had shoot through from hell, as it tried to short out the VBus and promptly blew up (violently)


Offline TMaxElectronics

  • High Voltage Technician
  • ***
  • Posts: 111
  • Karma: +5/-0
    • View Profile
    • My random (and very empty) electronics blog
Re: IGBTs keep dying (solved for now)
« Reply #41 on: July 02, 2020, 06:51:20 PM »
OK the caps are replaced, BUT the situation seems to still be similar...
I did a test run with 330A Ilim, which at 100us on time triggered almost all the time with more than 180V primary voltage. Turning it up resulted in moaaarrr power (obviously ;)), but it still kept triggering. once I turned up the primary voltage to the full 350V, the IGBT died once again...  ::)
On a positive note I am getting quite fast at taking apart the bridge and changing transistors&drivers  ;D

I measured the voltage across the bulk caps at that time:


I initially thought that it was good enough, but obviously wasn't. I realised kind of too late that I should probably measure directly across the IGBTs. After replacing the two transistors, I got this (directly on the screw terminals of the IGBTs):

This was at only 100V, with a very low (idk what exact level) current limit... and the Vpp was still significant.

My initial guess (before the second measurement) was that perhaps the OCD started sending random gate pulses, but further testing showed that it worked without issue (at least at a lower limiter level).
I also verified the top gate voltage, and detected no droop whatsoever, even if the idle state of that half was high. (only tested this at the limited current though)
So maybe the high current in the first test resulted in very high ringing voltages? But even if those peaks were significant, they would still need to exceed 300V to go above the VCEmax of the IGBTs  ???

And where does that ringing still come from now? With the two new caps we should be at ~125kHz resonance of the bus (maybe still too close)... I'm wondering if maybe an increase in inductance from the bulk caps might actually help in this case.
Just using a longer cable to attach them, instead of mounting the on the top upside down.

Max (the guy that has the other midi interrupter project) also had the idea that tuning was bad, resulting in poor energy transfer to the secondary, allowing the current to increase faster than normal, and was also concerned about the high ringing voltage, after the switching stopped.

And sorry about the screenshots coming from my phone, the diff. probe uses the power from the usb port ::)

EDIT:
I just tested this with the bulk caps connected trough cables, an it does seem to have reduced the frequency of the ringing, and almost removed the oscillations while switching. But the ringing is even larger than it was last time.
The caps were connected using ~10cm of welding cable. I'll try removing some of the film bypass caps tomorrow.

I also connected the CT to the scope again, as the first two images are extremely confusing without it.
« Last Edit: July 02, 2020, 10:21:09 PM by TMaxElectronics »

Online davekni

  • High Voltage Senior
  • *****
  • Posts: 691
  • Karma: +34/-0
  • Physicist, engineer (electronic), and hobbiest
    • View Profile
Re: IGBTs keep dying (un-solved again)
« Reply #42 on: July 03, 2020, 04:20:42 AM »
I'd suggest not removing any of your film capacitors, nor extending bulk cap connections.  It looks like the new VBus resonant frequency is now a bit closer to 1x primary frequency rather than 2x as it had been.  That can be seen as higher ripple voltage after enable ends.  (Most builds don't have an issue at 1x primary frequency since all IGBTs are off after enable ends.)  However, I wouldn't use caps to tweak frequency.

Instead, I'd work to block the magnetic field loop I described in a previous reply.  Ideally add some copper foil from the bulk cap bus bars that folds down over the film capacitors.  Or thinner strips from each conducting standoff across to the corresponding non-conductive standoff at the other end, passing along the outside edge of the bulk caps, and wide enough to go from almost the ECB to almost (or touching) the bus bars.  (The version with foil attached to the bus bars is a bit better.  It doesn't even need to make electrical contact along the bar.  Copper foil tape applied to the bus bars could connect only at the screws at the ends, and fold down over the film caps.)  The foil will both increase VBus resonant frequency and lower Q.

Voltage ringing on VBus at IGBTs will depend mostly on primary current, and only slightly on VBus voltage.  The short spikes may change more with voltage, but the main waveform shouldn't.  So, a good scoping of current and VBus voltage ripple will allow extrapolation to see if it's close to an issue (if ripple would approach 300V at full current).  You'll still need some additional margin for the short spikes.

A couple other possibilities on what may be causing frying:

1) With your off-state leaving two IGBTs enabled, those two are taking all the current after enable ends, rather than being split evenly among all four.  That also makes ring-down after enable last much longer since it's not feeding power back into VBus.  That makes higher transient thermal power for two IGBTs, starting after the die are already hot from the normal enable pulse operation.

2) During the enable pulse, IGBT diodes conduct relatively-small currents, only briefly between IGBT turn-off and current zero-crossing.  After enable ends, IGBT diodes conduct full primary current.  I wonder if forward-drop of the low-side IGBT diode is enough to over-charge that bootstrap capacitor and fry the gate driver chip.

3) Similar to (2) above, the low-side diode drop might directly violate driver-chip specifications for how far below ground the half-bridge output pin is allowed to go.  I haven't looked back at the thread to see which driver chip, so don't know if this is a likely issue or not.

Good luck on keeping IGBTs alive!
David Knierim

Offline TMaxElectronics

  • High Voltage Technician
  • ***
  • Posts: 111
  • Karma: +5/-0
    • View Profile
    • My random (and very empty) electronics blog
Re: IGBTs keep dying (un-solved again)
« Reply #43 on: July 04, 2020, 04:14:44 PM »
Quote
1) With your off-state leaving two IGBTs enabled, those two are taking all the current after enable ends, rather than being split evenly among all four.  That also makes ring-down after enable last much longer since it's not feeding power back into VBus.  That makes higher transient thermal power for two IGBTs, starting after the die are already hot from the normal enable pulse operation.
This might very well be part of the problem.

After a lot of thinking I have come to the conclusion that, since I need to re-design the logic in the driver anyway (the filter workarounds worked but were very crappy, and a workaround for the idle state would be hard), I may as well implement a commonly used design... You may even say a next-gen one ;)

So i have made a 100% compatible version of the UD3:

The silkscreen is fixed in the most recent revision ;)

I'll hopefully not continue the story with it in this thread :D

Quote
the low-side diode drop might directly violate driver-chip specifications for how far below ground the half-bridge output pin is allowed to go
Interesting idea. The driver has a VMax at the common connection of -9V if i understand the datasheet correctly. (https://www.st.com/resource/en/datasheet/l6494.pdf)
« Last Edit: July 04, 2020, 05:04:15 PM by TMaxElectronics »

Online davekni

  • High Voltage Senior
  • *****
  • Posts: 691
  • Karma: +34/-0
  • Physicist, engineer (electronic), and hobbiest
    • View Profile
Re: IGBTs keep dying (un-solved again)
« Reply #44 on: July 04, 2020, 08:56:15 PM »
Yes, -9V looks correct per that specification.  You'd almost certainly hit the VBoot-Vout absolute-maximum rating of 21V first.

Have fun with your UD3C!
David Knierim

Offline TMaxElectronics

  • High Voltage Technician
  • ***
  • Posts: 111
  • Karma: +5/-0
    • View Profile
    • My random (and very empty) electronics blog
Re: IGBTs keep dying (un-solved again)
« Reply #45 on: July 04, 2020, 10:35:50 PM »
Quote
You'd almost certainly hit the VBoot-Vout absolute-maximum rating of 21V first.
I'll measure it once the new driver is made. I also included an easily reachable pot for adjusting the gate drive voltage on the digital output/step down daughter board, so I can tune it more easily.

High Voltage Forum

Re: IGBTs keep dying (un-solved again)
« Reply #45 on: July 04, 2020, 10:35:50 PM »

 


* Recent Topics and Posts

post Re: Have you ever tripped a breaker during normal operation ?
[Dual Resonant Solid State Tesla coils (DRSSTC)]
panjaksli
Today at 07:34:53 PM
post Re: HF Litz wire as a primary coil
[Dual Resonant Solid State Tesla coils (DRSSTC)]
davekni
Today at 07:14:18 PM
post Re: Have you ever tripped a breaker during normal operation ?
[Dual Resonant Solid State Tesla coils (DRSSTC)]
davekni
Today at 07:05:18 PM
post Re: Have you ever tripped a breaker during normal operation ?
[Dual Resonant Solid State Tesla coils (DRSSTC)]
panjaksli
Today at 06:58:40 PM
post Re: Have you ever tripped a breaker during normal operation ?
[Dual Resonant Solid State Tesla coils (DRSSTC)]
Max
Today at 06:56:50 PM
post Re: Have you ever tripped a breaker during normal operation ?
[Dual Resonant Solid State Tesla coils (DRSSTC)]
profdc9
Today at 06:20:35 PM
post Re: Have you ever tripped a breaker during normal operation ?
[Dual Resonant Solid State Tesla coils (DRSSTC)]
panjaksli
Today at 05:24:23 PM
post Re: Have you ever tripped a breaker during normal operation ?
[Dual Resonant Solid State Tesla coils (DRSSTC)]
buchtawill
Today at 03:25:59 PM
post Re: Have you ever tripped a breaker during normal operation ?
[Dual Resonant Solid State Tesla coils (DRSSTC)]
panjaksli
Today at 03:02:01 PM
post Have you ever tripped a breaker during normal operation ?
[Dual Resonant Solid State Tesla coils (DRSSTC)]
panjaksli
Today at 01:36:04 PM
post Re: mini tesla (hopefully not a fail)
[Beginners]
bogdan
Today at 08:55:06 AM
post Re: HF Litz wire as a primary coil
[Dual Resonant Solid State Tesla coils (DRSSTC)]
johnf
Today at 07:43:14 AM
post Re: How to design FPGA based on EDA technology?
[Electronic Circuits]
Genterman
Today at 06:53:52 AM
post Re: DRSSTC trouble
[Dual Resonant Solid State Tesla coils (DRSSTC)]
davekni
Today at 03:29:14 AM
post Re: DRSSTC trouble
[Dual Resonant Solid State Tesla coils (DRSSTC)]
buchtawill
Today at 02:43:33 AM
post Re: SKP DRSSTC = aliexpress driver + medium coil + large bricks ;)
[Dual Resonant Solid State Tesla coils (DRSSTC)]
Maju
December 01, 2020, 10:44:31 PM
post Re: mini tesla (hopefully not a fail)
[Beginners]
davekni
December 01, 2020, 07:44:14 PM
post Re: transistor markings question
[Beginners]
davekni
December 01, 2020, 07:39:48 PM
post Re: HF Litz wire as a primary coil
[Dual Resonant Solid State Tesla coils (DRSSTC)]
davekni
December 01, 2020, 07:38:53 PM
post Re: How to design FPGA based on EDA technology?
[Electronic Circuits]
petespaco
December 01, 2020, 06:30:33 PM
post Re: Question about arduino polyphonic MIDI interrupter
[Dual Resonant Solid State Tesla coils (DRSSTC)]
bozidar
December 01, 2020, 04:58:29 PM
post Re: Question about arduino polyphonic MIDI interrupter
[Dual Resonant Solid State Tesla coils (DRSSTC)]
TMaxElectronics
December 01, 2020, 04:22:10 PM
post Re: Question about arduino polyphonic MIDI interrupter
[Dual Resonant Solid State Tesla coils (DRSSTC)]
bozidar
December 01, 2020, 03:02:51 PM
post Re: Half-brigde with pot on mosfet gates question
[Solid State Tesla Coils (SSTC)]
TMaxElectronics
December 01, 2020, 12:08:56 PM
post transistor markings question
[Beginners]
NOOBPASTE51
December 01, 2020, 12:02:19 PM
post Re: Question about arduino polyphonic MIDI interrupter
[Dual Resonant Solid State Tesla coils (DRSSTC)]
TMaxElectronics
December 01, 2020, 11:55:01 AM
post Re: HF Litz wire as a primary coil
[Dual Resonant Solid State Tesla coils (DRSSTC)]
TMaxElectronics
December 01, 2020, 11:50:19 AM
post Re: Analog HFBR amplifier
[Electronic Circuits]
TMaxElectronics
December 01, 2020, 11:21:56 AM
post Half-brigde with pot on mosfet gates question
[Solid State Tesla Coils (SSTC)]
costas_p
December 01, 2020, 11:17:16 AM
post Re: Question about arduino polyphonic MIDI interrupter
[Dual Resonant Solid State Tesla coils (DRSSTC)]
bozidar
December 01, 2020, 11:11:50 AM
post Re: mini tesla (hopefully not a fail)
[Beginners]
bogdan
December 01, 2020, 09:29:24 AM
post Re: HF Litz wire as a primary coil
[Dual Resonant Solid State Tesla coils (DRSSTC)]
johnf
December 01, 2020, 07:03:56 AM
post Re: How to design FPGA based on EDA technology?
[Electronic Circuits]
johnf
December 01, 2020, 06:49:26 AM
post Re: SSTC or DRSSTC with GaN Transistors
[Solid State Tesla Coils (SSTC)]
Steve Ward
December 01, 2020, 04:59:28 AM
post How to design FPGA based on EDA technology?
[Electronic Circuits]
Genterman
December 01, 2020, 04:02:06 AM
post Re: DRSSTC trouble
[Dual Resonant Solid State Tesla coils (DRSSTC)]
davekni
December 01, 2020, 03:46:10 AM
post Re: DRSSTC trouble
[Dual Resonant Solid State Tesla coils (DRSSTC)]
buchtawill
December 01, 2020, 02:00:54 AM
post Re: HF Litz wire as a primary coil
[Dual Resonant Solid State Tesla coils (DRSSTC)]
Steve Ward
December 01, 2020, 01:47:10 AM
post Re: DRSSTC trouble
[Dual Resonant Solid State Tesla coils (DRSSTC)]
davekni
December 01, 2020, 12:02:23 AM
post Re: Site Info desperately needed: http://www.stevehv.4hv.org/
[General Chat]
Mads Barnkob
November 30, 2020, 10:28:56 PM
post Re: I started making a drsstc
[Dual Resonant Solid State Tesla coils (DRSSTC)]
Miki_407
November 30, 2020, 08:58:41 PM
post DRSSTC trouble
[Dual Resonant Solid State Tesla coils (DRSSTC)]
buchtawill
November 30, 2020, 08:53:00 PM
post Re: I started making a drsstc
[Dual Resonant Solid State Tesla coils (DRSSTC)]
davekni
November 30, 2020, 08:49:30 PM
post Re: Simple H-Bridge construction with low parasitic inductances (for SSTC or ...)
[Beginners]
davekni
November 30, 2020, 08:45:46 PM
post Re: mini tesla (hopefully not a fail)
[Beginners]
davekni
November 30, 2020, 06:56:13 PM
post Re: I started making a drsstc
[Dual Resonant Solid State Tesla coils (DRSSTC)]
Miki_407
November 30, 2020, 01:16:04 PM
post Re: I started making a drsstc
[Dual Resonant Solid State Tesla coils (DRSSTC)]
Mads Barnkob
November 30, 2020, 12:56:05 PM
post Re: mini tesla (hopefully not a fail)
[Beginners]
bogdan
November 30, 2020, 12:03:06 PM
post I started making a drsstc
[Dual Resonant Solid State Tesla coils (DRSSTC)]
Miki_407
November 30, 2020, 11:58:29 AM
post Re: Interesting 2400W power supply circuit
[Electronic Circuits]
Kiki
November 30, 2020, 07:58:52 AM

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 
SimplePortal 2.3.6 © 2008-2014, SimplePortal