Author Topic: First SSTC build, need help troubleshooting  (Read 1279 times)

Offline Jesjes

  • High Voltage Enthusiast
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
First SSTC build, need help troubleshooting
« on: December 01, 2018, 03:38:37 AM »
Hi all, its my first time building a SSTC and Im having trouble with the gate drive transformer.

Im using Steve Ward's mini sstc schematic and the timer circuit is working fine, outputting a good square wave with a frequency from 425 hz to 1.3 khz. At this point Ive wrapped 4 different GDTs and purchased a Hirel 050100 1:1:1 GDT. Each one gives a terrible waveform to drive the mosfets. What can I do to try to fix this? Any suggestions are much appreciated.

Offline Fumeaux

  • High Voltage Experimenter
  • **
  • Posts: 60
  • Karma: +7/-0
    • View Profile
Re: First SSTC build, need help troubleshooting
« Reply #1 on: December 01, 2018, 09:15:01 PM »
Hi Jesjes,

i don't know the exact answer to your problem, but i have some ideas.
-) If you don't have your mosfets/igbts connectes while measuring, try it with them connected. Those components have a gatecapacitiy which will change the waveform.
-) Can you provide pictures of the timer circuit waveform while the UCC's are connected
-) Can you post a picture of your driver/setup
-) Is this the schematic we are talking about: http://www.stevehv.4hv.org/SSTC5/miniSSTCsch.JPG
-) or this: http://www.stevehv.4hv.org/SSTC5/miniSSTCfnlsch.JPG
-) Is your supply voltage regulated and smooth? both the 5v and the 12V?
-) Are you sure you used all the right components? one ucc37321 and one ucc37322? and the other components too
-) Have you meassued if there are any shorts?
-) Can you test if a chip is faulty by replacing it?

Offline Mads Barnkob

  • Administrator
  • High Voltage Expert
  • *****
  • Posts: 1016
  • Karma: +16/-0
  • Denmark
    • View Profile
    • Kaizer Power Electronics
Re: First SSTC build, need help troubleshooting
« Reply #2 on: December 02, 2018, 09:57:04 AM »
Hi jesjes and welcome to HVF

Fumeaux said all the right things, first and foremost we need more information to help you :)

A very good first troubleshooting step is looking at the waveform: http://www.richieburnett.co.uk/temp/gdt/gdt2.html

Your DSO138 might not have the sample rate/bandwidth needed to measure these waveforms true to their real form, please check with a real oscilloscope if possible.

Some of the toroid cores you showed looks like iron powder cores, did you get some high permability material cores with AL above 5000? The Hirel I assume would be in a working region for this.
http://www.kaizerpowerelectronics.dk - Tesla coils, high voltage, pulse power, audio and general electronics

Offline Jesjes

  • High Voltage Enthusiast
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: First SSTC build, need help troubleshooting
« Reply #3 on: December 03, 2018, 05:31:29 AM »
Thanks for the suggestions Fumeaux and Mads,

-I connected the transistors to the GDT and still got the ringing on the GDT's output (see 1st attachment).
-When probing the timer output with UCC's connected, the waveform is still a good square wave( see 2nd attachment).
-Attachment 3 & 4 are my timer and gate drive circuits, and my complete setup for testing.
-I'm following the final schematic: http://www.stevehv.4hv.org/SSTC5/miniSSTCfnlsch.JPG
-For power, im using a 12v 5a adapter. I kept the two 1000uF capacitors in the supply, but omitted the 2200, as it didnt seem necessary without the rectified 20v. The power supply is smooth and seems to be working fine.
-The only difference in components used was some 1n4004 diodes instead of 1n4007 in the 555 schematic.
-I could not find any shorts in the circuit, and changed out the ICs, but sadly that didnt change much in the GDT output.

-The Hirel GDT doesnt list AL value, but gives an operating range of 50-250 khz. I did purchase a toroid from Digikey (blue core in my first post) with a AL of 10000 +- 30%, however i got similar results from that core. It was an EPCOS B64290L0618X038.
-Ive been worried the DSO may not be giving the true waveform, as it has a max frequency of 200khz. Hopefully my school will have a nicer one i can use.

-Ive also attached the waveform (attachment 5) while probing the drain to source of one of the transistors, and got a square wave output. However I am worried that the odd waveform from the GDT will cause overheating in the mosfets when I increase the input voltage. With rectified and smootch 20vdc the transistors went from 71f to above 125f.

Offline sjsimmo

  • High Voltage Enthusiast
  • *
  • Posts: 34
  • Karma: +3/-0
  • Australia
    • View Profile
Re: First SSTC build, need help troubleshooting
« Reply #4 on: December 03, 2018, 08:40:43 AM »
Hi Jesjes,

I'm fairly new to this stuff, but I have some theories as to what is causing your problem :).

What is the waveform on pin 2 of the UCCs? (this should be a square-wave at the secondary coil's resonant frequency). It may be that the circuit isn't getting enough feedback, which would result in a single pulse on the GDT input each time the 555 timer outputs a 12v signal. Thus resulting in ringing on the GDT output due to a resonant circuit involving C6 and the GDT primary.

If this is the case, increasing the bus voltage and/or moving the antenna closer to the secondary may fix your problem.
I like my food cooked with lightning.

Offline Fumeaux

  • High Voltage Experimenter
  • **
  • Posts: 60
  • Karma: +7/-0
    • View Profile
Re: First SSTC build, need help troubleshooting
« Reply #5 on: December 03, 2018, 10:35:13 AM »
Hi Jesjes,

I think that sjsimmo is right about the feedback being too weak. But I want to see some more waveforms just to be sure. Mainly what kind of signal the feedback gives and what waveform goes into to gdt. The schematics that don't have a clock (like yours) starting the oscilation sometimes don't like to start on their own, so you might have to look into a different schematic.


I made some sketches for you. And I mean osci once the signal on pin 2 of the UCC's and once the waveform on the gdt.

And I'm sure that the timer is not the problem.



Offline Jesjes

  • High Voltage Enthusiast
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: First SSTC build, need help troubleshooting
« Reply #6 on: December 09, 2018, 04:50:56 AM »
Hey guys,

So I probed around my antenna and hex inverter. The first 2 attachments are waveforms on the diode side of c3. The last 2 are of the output of the inverter to the gate drivers. Im not 100% certain of the waveforms as the dso138 has fairly poor resolution. However, it does seem like there is a weak feedback issue with the antenna. 5th attachment is my antenna placement. Maybe it needs to be longer or shorter?

I am only driving the circuit with 20v dc and with the configuration of the halfbridge side, only putting 10v into the primary each cycle. Could the field being produced by the coil not have enough energy to bring the feedback up to 5v? Im worried about increasing the voltage as my transistors are extremely hot after a minute or two at 20v. I have ordered a much larger heatsink so that should help.

I was able to get a fluorescent bulb to flicker when placed right next to the secondary :), which shows the coil is slightly working. No sparks off of the breakout point though.

Let me know what you guys think.

Offline Fumeaux

  • High Voltage Experimenter
  • **
  • Posts: 60
  • Karma: +7/-0
    • View Profile
Re: First SSTC build, need help troubleshooting
« Reply #7 on: December 09, 2018, 10:23:38 AM »
I still think that the feedback is too weak. You need a feedbacksignal with about 2.5V or else the schmitttrigger wont trigger.



And the heating problem is probably a result of the bad gdt waveform. But a better feedbacksignal should result in a better waveform and as a result less heat. Or a bang.

I guess the flickering was a result of the interrupter sending out pulses

The pulses have 1ms or 2ms inbetween, which means 1000-500Hz
« Last Edit: December 09, 2018, 10:31:26 AM by Fumeaux »

Offline sjsimmo

  • High Voltage Enthusiast
  • *
  • Posts: 34
  • Karma: +3/-0
  • Australia
    • View Profile
Re: First SSTC build, need help troubleshooting
« Reply #8 on: December 09, 2018, 11:09:34 PM »
I also think that the feedback is too weak.
I'd try making the antenna longer, as this should strengthen the feedback signal.  :)

Also, have you tried swapping the GDT inputs or the primary wires? If you haven't already, do this first. It could be that the circuit is out of phase...
I like my food cooked with lightning.

Offline Mads Barnkob

  • Administrator
  • High Voltage Expert
  • *****
  • Posts: 1016
  • Karma: +16/-0
  • Denmark
    • View Profile
    • Kaizer Power Electronics
Re: First SSTC build, need help troubleshooting
« Reply #9 on: December 10, 2018, 09:13:37 AM »
Hey guys,

So I probed around my antenna and hex inverter. The first 2 attachments are waveforms on the diode side of c3. The last 2 are of the output of the inverter to the gate drivers. Im not 100% certain of the waveforms as the dso138 has fairly poor resolution. However, it does seem like there is a weak feedback issue with the antenna. 5th attachment is my antenna placement. Maybe it needs to be longer or shorter?

I am only driving the circuit with 20v dc and with the configuration of the halfbridge side, only putting 10v into the primary each cycle. Could the field being produced by the coil not have enough energy to bring the feedback up to 5v? Im worried about increasing the voltage as my transistors are extremely hot after a minute or two at 20v. I have ordered a much larger heatsink so that should help.

I was able to get a fluorescent bulb to flicker when placed right next to the secondary :), which shows the coil is slightly working. No sparks off of the breakout point though.

Let me know what you guys think.

Get rid of the DSO138 and find a cheap/for free old 20 MHz analog oscilloscope instead, it will do you much better :)

I agree with the others, you are running at a too low input voltage to expect to see any real working circuit, your antenna could also go up to half the height of the secondary coil, then retract it if there is sparks forming on its tip, a little corona is normal, but not sparks .

If you have a flickering fluorescent bulb, you are good to go, I assume you are using a variac, so get up to at-least 100V input.
http://www.kaizerpowerelectronics.dk - Tesla coils, high voltage, pulse power, audio and general electronics

Offline Jesjes

  • High Voltage Enthusiast
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: First SSTC build, need help troubleshooting
« Reply #10 on: January 02, 2019, 06:45:11 PM »
Hey guys, hope everyone had a good holiday season.

Spent a little time working on my circuits and making sure everything was right. I thought I had everything working and wired correctly, but when I turn up my variac voltage, my KBU1510 bridge rectifier keeps failing. After checking my circuit, I found that my 555 circuit has also stopped working, just outputs a fixed 12v. I haven't messed with this at all and it was working before I started using my variac. I replaced the 555 and got the same result. I checked the component values with my multimeter and everything seems to have correct values. Any suggestions to get it working again?

Offline Mads Barnkob

  • Administrator
  • High Voltage Expert
  • *****
  • Posts: 1016
  • Karma: +16/-0
  • Denmark
    • View Profile
    • Kaizer Power Electronics
Re: First SSTC build, need help troubleshooting
« Reply #11 on: January 03, 2019, 12:12:38 PM »
If you have a bridge rectifier failing it is either from overload or a short-circuit.

What does the current draw look like on the AC line when you use the variac? If it is quickly rising you have a short-circuit somewhere in the inverter power section.

Best thing to do with faults like this is separate the system into smaller parts and test separately. This can even mean that you have to desolder things like gate resistors in order to measure them for faults.
http://www.kaizerpowerelectronics.dk - Tesla coils, high voltage, pulse power, audio and general electronics

Offline TDAF

  • High Voltage Technician
  • ***
  • Posts: 108
  • Karma: +4/-0
    • View Profile
Re: First SSTC build, need help troubleshooting
« Reply #12 on: January 06, 2019, 09:45:17 AM »
Well, first things first you should be getting a proper oscilloscope
Those DIY kits aren't good for anything beyond a kilohert or two

High Voltage Forum

Re: First SSTC build, need help troubleshooting
« Reply #12 on: January 06, 2019, 09:45:17 AM »

 


* Recent Topics and Posts

post Re: Choke-input DC-filter
[Electronic circuits]
johnf
Today at 08:58:07 PM
post Re: CRT hacking ideas....
[Electronic circuits]
badpeter
Today at 07:28:00 PM
post Re: Ideas needed!
[General chatting]
MRMILSTAR
Today at 05:13:57 PM
post Re: Why did 4HV die??
[General chatting]
MRMILSTAR
Today at 05:07:41 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
Bert911
Today at 02:14:55 PM
post Re: Choke-input DC-filter
[Electronic circuits]
kamelryttarn
Today at 12:53:58 PM
post Re: Choke-input DC-filter
[Electronic circuits]
johnf
Today at 12:09:27 PM
post Choke-input DC-filter
[Electronic circuits]
kamelryttarn
Today at 11:43:58 AM
post Re: Welcome new members, come say hello and tell a little about yourself :)
[General chatting]
shrad
Today at 08:57:42 AM
post Re: adventures in homemade flyback bobbins.
[Transformer (ferrite core)]
Patrick
Today at 04:06:00 AM
post Re: Welcome new members, come say hello and tell a little about yourself :)
[General chatting]
johnf
Today at 03:50:56 AM
post Re: CRT hacking ideas....
[Electronic circuits]
petespaco
June 19, 2019, 11:29:28 PM
post Re: A dynamical arc model v2
[Dual Resonant Solid State Tesla coils]
Uspring
June 19, 2019, 01:40:16 PM
post Re: Welcome new members, come say hello and tell a little about yourself :)
[General chatting]
Mads Barnkob
June 19, 2019, 10:49:45 AM
post Re: A dynamical arc model v2
[Dual Resonant Solid State Tesla coils]
Mads Barnkob
June 19, 2019, 10:43:32 AM
post Re: Light, laser and optics - Link collection
[Light, lasers and optics]
shrad
June 19, 2019, 10:03:54 AM
post Re: How go get single mode optic fiber to work
[Light, lasers and optics]
shrad
June 19, 2019, 10:02:21 AM
post Re: Welcome new members, come say hello and tell a little about yourself :)
[General chatting]
shrad
June 19, 2019, 09:35:52 AM
post Re: CRT hacking ideas....
[Electronic circuits]
badpeter
June 18, 2019, 11:35:16 PM
post Re: CRT hacking ideas....
[Electronic circuits]
Mads Barnkob
June 18, 2019, 08:22:23 PM
post CRT hacking ideas....
[Electronic circuits]
badpeter
June 18, 2019, 07:20:16 PM
post Re: Is one of these good?
[Dual Resonant Solid State Tesla coils]
VNTC
June 18, 2019, 12:16:43 PM
post Re: A dynamical arc model v2
[Dual Resonant Solid State Tesla coils]
Uspring
June 18, 2019, 11:45:53 AM
post Re: Next Gen DRSSTC
[Dual Resonant Solid State Tesla coils]
Netzpfuscher
June 17, 2019, 09:01:29 PM
post Re: A dynamical arc model v2
[Dual Resonant Solid State Tesla coils]
Mads Barnkob
June 17, 2019, 08:54:41 PM
post Re: Bought huge capacitors
[Capacitor banks]
MRMILSTAR
June 17, 2019, 04:34:02 PM
post Re: How energy flow through a DRSSTC?
[Dual Resonant Solid State Tesla coils]
Uspring
June 17, 2019, 03:13:03 PM
post Re: A dynamical arc model v2
[Dual Resonant Solid State Tesla coils]
Uspring
June 17, 2019, 02:40:06 PM
post Re: What happens when L and C are not matched?
[Electronic circuits]
klugesmith
June 17, 2019, 01:17:36 PM
post Re: Next Gen DRSSTC
[Dual Resonant Solid State Tesla coils]
Mads Barnkob
June 17, 2019, 11:13:33 AM
post Re: Where to buy Tesla coil capacitors?
[Spark gap Tesla coils]
Mads Barnkob
June 17, 2019, 10:46:56 AM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
Bert911
June 17, 2019, 08:01:10 AM
post Re: A dynamical arc model v2
[Dual Resonant Solid State Tesla coils]
VNTC
June 17, 2019, 04:19:07 AM
post How energy flow through a DRSSTC?
[Dual Resonant Solid State Tesla coils]
VNTC
June 17, 2019, 04:05:33 AM
post Re: Tungsten
[Spark gap Tesla coils]
thedoc298
June 17, 2019, 12:02:39 AM
post Re: My first DRSSTC on bricks
[Dual Resonant Solid State Tesla coils]
Laci
June 16, 2019, 09:00:31 PM
post Re: Bought huge capacitors
[Capacitor banks]
dexter
June 16, 2019, 08:25:16 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
hightemp1
June 16, 2019, 07:06:48 PM
post Re: Bought huge capacitors
[Capacitor banks]
MRMILSTAR
June 16, 2019, 06:07:06 PM
post Re: Next Gen DRSSTC
[Dual Resonant Solid State Tesla coils]
Hydron
June 16, 2019, 04:51:26 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
petespaco
June 16, 2019, 03:39:30 PM
post Re: Next Gen DRSSTC
[Dual Resonant Solid State Tesla coils]
Netzpfuscher
June 16, 2019, 03:39:15 PM
post Re: Next Gen DRSSTC
[Dual Resonant Solid State Tesla coils]
Hydron
June 16, 2019, 03:18:25 PM
post Re: A dynamical arc model v2
[Dual Resonant Solid State Tesla coils]
Hydron
June 16, 2019, 03:10:15 PM
post Re: Bought huge capacitors
[Capacitor banks]
Max
June 16, 2019, 12:25:59 PM
post Re: Help for people buying the "12-48 Volt 1800/2500 Watt ZVS induction Heater"
[Electronic circuits]
Bert911
June 16, 2019, 09:38:15 AM
post Re: Top of secondary
[Spark gap Tesla coils]
MRMILSTAR
June 16, 2019, 05:45:47 AM
post Re: Tungsten
[Spark gap Tesla coils]
MRMILSTAR
June 16, 2019, 05:40:52 AM
post Tungsten
[Spark gap Tesla coils]
thedoc298
June 16, 2019, 03:51:12 AM
post Re: Last question
[Spark gap Tesla coils]
thedoc298
June 16, 2019, 03:44:43 AM

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30